20TB+名家课程 提交需求

    好用分时指标(大智慧)

    分类:大智慧公式 关注:1447 来源:一百万教程网(Www.Gpzyw.Net) Tmie:2017/8/21 10:23:14

    好用分时指标,请高手在优化一下,最好做个分时预警(机构买线上穿机构卖线)


    VAR0:=VOL/CLOSE/2;

    VAR1:=SUM(IF(VAR0 > 100 AND CLOSE > REF(CLOSE,1),VAR0,0),0);

    VAR2:=SUM(IF(VAR0 > 100 AND CLOSE < REF(CLOSE,1),VAR0,0),0);

    VAR3:=SUM(IF(VAR0 < 100 AND CLOSE > REF(CLOSE,1),VAR0,0),0);

    VAR4:=SUM(IF(VAR0 < 100 AND CLOSE < REF(CLOSE,1),VAR0,0),0);

    VAR5:=VAR1 + VAR2 + VAR3 + VAR4;

    VAR6:=IF(BARSTATUS=2,100 * VAR1/VAR5,0);

    VAR7:=IF(BARSTATUS=2,100 * VAR2/VAR5,0);

    VAR8:=IF(BARSTATUS=2,100 * VAR3/VAR5,0);

    VAR9:=IF(BARSTATUS=2,100 * VAR4/VAR5,0);

    机构买盘:VAR1,LINETHICK3,COLORFF55FF;

    机构卖盘:VAR2,LINETHICK3,COLORFFFF55;

    散户买盘:VAR3,COLOR5555FF;

    散户卖盘:VAR4,COLOR55FF55;

    DRAWTEXTREL(950,870,'机构买盘'),COLORFF00ff;

    DRAWTEXTREL(950,570,'机构卖盘'),COLORFFFF00;

    DRAWTEXTREL(950,320,'散户买盘'),COLOR0000FF;

    DRAWTEXTREL(950,50,'散户卖盘'),COLOR00FF00;

    IF BARSTATUS=2 THEN BEGIN

    DRAWTEXTREL(1030,870,'' + FLOOR(VAR6) + '%'),COLORFF00FF;

    END

    IF BARSTATUS=2 THEN BEGIN

    LOOP0:=FLOOR(VAR7);

    VAR10:='' + LOOP0;

    VAR11:=VAR10 + '%';

    DRAWTEXTREL(1030,570,VAR11),COLORFFFF00;

    END

    IF BARSTATUS=2 THEN BEGIN

    LOOP1:=FLOOR(VAR8);

    VAR12:='' + LOOP1;

    VAR13:=VAR12 + '%';

    DRAWTEXTREL(1030,320,VAR13),COLOR0000FF;

    END

    IF BARSTATUS=2 THEN BEGIN

    LOOP2:=FLOOR(VAR9);

    VAR14:='' + LOOP2;

    VAR15:=VAR14 + '%';

    DRAWTEXTREL(1030,50,VAR15),COLOR00FF00;

    END;



     

    一百万教程网
    一百万教程网
    一百万教程网