20TB+名家课程 提交需求

    出于MACD胜过MACD(大智慧)

    分类:大智慧公式 关注:1491 来源:一百万教程网(Www.Gpzyw.Net) Tmie:2017/8/21 10:23:29

    SQX:=(C-MA(CLOSE,13))*100;

    DIFF:EMA(MA(SQX,7),1),COLORWHITE;

    DEA:EMA(DIFF,7),COLORYELLOW;

    MACD:(DIFF-DEA)*2,COLORSTICK;

    PARTLINE(15,CROSS(DIFF,DEA) AND DIFF<-0.1),COLORYELLOW,LINETHICK4,CROSSDOT;

    低位金叉:IF(CROSS(DIFF,DEA) AND DIFF<-0.1,15,0),COLORYELLOW,LINETHICK0;

    JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));

    PARTLINE(28,CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1),COLORFF00FF,LINETHICK4,CROSSDOT;

    二次金叉:IF(CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1,28,0),COLORFF00FF,LINETHICK0;

    A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

    PARTLINE(40,REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA)),COLORRED,LINETHICK4,CROSSDOT;

    底背离:IF(REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA),40,0),COLORRED,LINETHICK0;

    势: DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORGREEN;{,COLORRED;}

    A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));

    顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);

    PARTLINE(66,REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF)),COLORF08000,LINETHICK4,CROSSDOT;

    顶背离_:IF(REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF),66,0),COLORF08000,LINETHICK0;

    压: DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORFFBB99;

    A3:=CROSS(DIFF,DEA) AND DEA<0;

    PARTLINE(53,FILTER(COUNT(A3,21)=2,10)),COLORWHITE,LINETHICK4,CROSSDOT;

    零下二次金叉_:IF(FILTER(COUNT(A3,21)=2,10),53,0),COLORWHITE,LINETHICK0;

    DRAWICON(CROSS(DIFF,DEA) ,DIFF,7),LAYER0,ALIGN1;

    DRAWICON(CROSS(DEA,DIFF) , DEA,8),LAYER0,ALIGN1;

    金叉:if(CROSS(DIFF,DEA),diff,0),color00ff00,stick,linethick1;

    死叉:if(CROSS(DEA,DIFF),diff,0),colorff0099,stick,linethick1;

     



     

    一百万教程网
    一百万教程网
    一百万教程网