一百万教程网

飞狐江恩百分比主图指标公式

Class:飞狐公式 Time:2017-7-26 Hits:1458

input:w(2,1,3);

u1:=sysparam(3);

u:=u1-sysparam(2)+1;

hh:=hhv(H,u);

ll:=llv(L,u);

最高:=hh[u1],COLORYELLOW;

PARTLINE(C and w<>3,最高),COLORYELLOW;

最低:ll[u1],COLORred;

PARTLINE(C and w<>3,最低),COLORred;

PARTLINE(C and w=1,最低+(最高-最低)*0.191),LINEDOT,COLORWHITE;

PARTLINE(C and w=1,最低+(最高-最低)*0.382),LINEDOT,COLORWHITE;

PARTLINE(C and w<>3,最低+(最高-最低)*0.5),COLORGREEN;

PARTLINE(C and w=1,最低+(最高-最低)*0.618),LINEDOT,COLORWHITE;

PARTLINE(C and w=1,最低+(最高-最低)*0.809),LINEDOT,COLORWHITE;

DRAWTEXT(BARSCOUNT(C)=SYSPARAM(3) and w<>3,REF(最低,BARSLAST(BARSCOUNT(C)=SYSPARAM(2))),'最低&darr;'),ALIGN2,COLORred;

DRAWTEXT(BARSCOUNT(C)=SYSPARAM(3) and w<>3,REF(最高,BARSLAST(BARSCOUNT(C)=SYSPARAM(2))),'最高&uarr;'),ALIGN2,COLORYELLOW;

DRAWTEXT(BARPOS=SYSPARAM(2) and w=1,REF((最低+(最高-最低)*0.191)*0.996,BARSLAST(BARSCOUNT(C)=SYSPARAM(2))),'黄金 0.191&uarr;'+NUMTOSTR(最低+(最高-最低)*0.191,2)),COLORWHITE;

DRAWTEXT(BARPOS=SYSPARAM(2) and w=1,REF((最低+(最高-最低)*0.382)*0.996,BARSLAST(BARSCOUNT(C)=SYSPARAM(2))),'黄金 0.382&uarr;'+NUMTOSTR(最低+(最高-最低)*0.382,2)),COLORWHITE;

DRAWTEXT(BARPOS=SYSPARAM(2) and w<>3,REF((最低+(最高-最低)*0.5)*0.996,BARSLAST(BARSCOUNT(C)=SYSPARAM (2))),' 50% &uarr;'+NUMTOSTR(最低+(最高-最低)*0.5,2)),COLORGREEN;

DRAWTEXT(BARPOS=SYSPARAM(2) and w=1,REF((最低+(最高-最低)*0.618)*0.996,BARSLAST(BARSCOUNT(C)=SYSPARAM(2))),'黄金 0.618&uarr;'+NUMTOSTR(最低+(最高-最低)*0.618,2)),COLORWHITE;

DRAWTEXT(BARPOS=SYSPARAM(2) and w=1,REF((最低+(最高-最低)*0.809)*0.996,BARSLAST(BARSCOUNT(C)=SYSPARAM(2))),'黄金 0.809&uarr;'+NUMTOSTR(最低+(最高-最低)*0.809,2)),COLORWHITE;

{ Gpzyw.net 股票资源网_飞狐股票指标公式}

PARTLINE(C and w=2,最低+(最高-最低)*1/8),LINEDOT,Color0095BC;

PARTLINE(C and w=2,最低+(最高-最低)*1/4),LINEDOT,Color0095BC;

PARTLINE(C and w=2,最低+(最高-最低)*3/8),LINEDOT,Color0095BC;

PARTLINE(C and w=2,最低+(最高-最低)*5/8),LINEDOT,Color0095BC;

PARTLINE(C and w=2,最低+(最高-最低)*7/8),LINEDOT,Color0095BC;

PARTLINE(C and w=2,最低+(最高-最低)*3/4),LINEDOT,Color0095BC;

DRAWTEXT(BARPOS=SYSPARAM(2) and w=2,REF((最低+(最高-最低)*1/8)*0.996,BARSLAST(BARSCOUNT(C)=SYSPARAM(2))),'江恩 1/8&uarr;'+NUMTOSTR(最低+(最高-最低)*1/8,2)),Color0095BC;

DRAWTEXT(BARPOS=SYSPARAM(2) and w=2,REF((最低+(最高-最低)*1/4)*0.996,BARSLAST(BARSCOUNT(C)=SYSPARAM(2))),'江恩 1/4&uarr;'+NUMTOSTR(最低+(最高-最低)*1/4,2)),Color0095BC;

DRAWTEXT(BARPOS=SYSPARAM(2) and w=2,REF((最低+(最高-最低)*3/8)*0.996,BARSLAST(BARSCOUNT(C)=SYSPARAM(2))),'江恩 3/8&uarr;'+NUMTOSTR(最低+(最高-最低)*3/8,2)),Color0095BC;

DRAWTEXT(BARPOS=SYSPARAM(2) and w=2,REF((最低+(最高-最低)*5/8)*0.996,BARSLAST(BARSCOUNT(C)=SYSPARAM(2))),'江恩 5/8&uarr;'+NUMTOSTR(最低+(最高-最低)*5/8,2)),Color0095BC;

DRAWTEXT(BARPOS=SYSPARAM(2) and w=2,REF((最低+(最高-最低)*7/8)*0.996,BARSLAST(BARSCOUNT(C)=SYSPARAM(2))),'江恩 7/8&uarr;'+NUMTOSTR(最低+(最高-最低)*7/8,2)),Color0095BC;

DRAWTEXT(BARPOS=SYSPARAM(2) and w=2,REF((最低+(最高-最低)*3/4)*0.996,BARSLAST(BARSCOUNT(C)=SYSPARAM(2))),'江恩 3/4&uarr;'+NUMTOSTR(最低+(最高-最低)*3/4,2)),Color0095BC;




 

{一百万教程网,http://ybwsoft.net,友情提供}
股票教程网所有股票公式,仅供学习研究,只有参考价值,请勿以此为依据进行股票交易!

本站所有公式全部免费,如果这条公式对您有价值,或有帮助,请打开微信,扫一扫下面的二维码,赞助本站,金额随意!

感谢您对支持我们的发展和对我们工作的肯定!小编在些表示感谢!

本站提供通达信选股公式,看盘主图副图指标,编写,修改,DLL加密等业务,详询客服!